25

Currently, the font specification calls Georgia as the primary serif font for question titles. While undeniably an attractive font, its zero renders almost exactly the same as a lower case letter 'o'. This introduces a significant level of ambiguity:

Georgia rendering a zero

While I think it extremely unlikely that there is a serif font that is readily available on most Unix user's machines that would have a slashed or dotted zero (the ideal), with only a small tweak to the CSS, it would be possible to improve the rendering of zeros for most users:

Times as the default

I'm reluctant to suggest a significant change as I think the overall look of the site is extremely professional - however, for a site for coders and geeks, having ambiguous zeros is rather unfortunate1.

With only a small change to the stylesheet, this can be improved. From:

#question-header .question-hyperlink {
     color: #155078;
     font-family: Georgia,"Times New Roman",Times,serif;
     font-size: 24px;
     ...
}

to:

#question-header .question-hyperlink {
     color: #155078;
     font-family: "Times New Roman",Times,serif;
     font-size: 28px;
     ...
}

Is this something that others are similarly exercised about? Could it be considered for a change?

Other example questions where this has an impact (mentioned in chat):

UPDATE

Updated to highlight a couple of particularly egregious examples:

A shocker...

another more recent example of fail

  • 1
    Your CSS might not be the final correct change. #question-header might not catch the ones in the question list, a more generic a.question-hyperlink might be in order. In any case that's for the site designer to work out. – Caleb Aug 4 '11 at 11:27
  • Looks like “this” bug has returned from the dead, thanks to the One-Font-To-Rule-Them-All responsivity theme. But seriously, these are simply text figures. That’s how they are supposed to work. There is no bug. But probably you would do better with a face that had slashed zeroes. Courier? :) – tchrist Nov 4 '18 at 21:45
  • See please this search for 0s. – tchrist Nov 4 '18 at 21:52
10

I too think this design could use addressing. As I mentioned in chat I have been bothered by this before and was going to bring it up on Meta and kept forgetting. Thanks for bringing it up.

I'm not attached to any particular choice so long as it's glyphs for key characters that matter to Unix related questions (like the number zero and letter o) are sufficiently distinct.

3

Historical note: this was changed to use Liberation Serif between April 16th of 2013 and August 9th 2018; this effectively resolved the issue. Since the more recent switch back to Georgia for the title font, the issue has returned (at least on Windows).

  • 1
    Thank you: that looks so much better. – jasonwryan Apr 16 '13 at 0:39
  • Sklivvz is the man. I believe he even uses some Apple-flavored Unix... – Shog9 Apr 16 '13 at 0:43
  • This still looks poor to me. Is it because I don't have the Liberation font? – Barmar Nov 26 '14 at 19:21
  • I don't know, @Barmar - do you have the Liberation font? – Shog9 Nov 26 '14 at 21:34
  • Probably not. Unless it's a standard font on OS X Snow Leopard, I probably don't. – Barmar Nov 26 '14 at 21:35
  • I don't think I've ever installed any third-party fonts. And I don't see any results in the browser if I remove Liberation from the fonts of that style, so it must be using Georgia. – Barmar Nov 26 '14 at 21:36
  • 1
    I recommend that you remove that shiny red status-completed from this post, since it no longer completed nor fixed, but indeed regressed thanks to Mordor’s shiny new One-Font-To-Rule-Them-All ⁽ᵃⁿᵈ ⁱⁿ ᵗʰᵉ ᵈᵃʳᵏⁿᵉˢˢ ᵇⁱⁿᵈ ᵗʰᵉᵐ⁾ policy. – tchrist Nov 4 '18 at 21:38
  • Grrr... Weird thing here is that it looks great on Android - 0 O o are all very distinct in size and shape. On Windows, 0 and o are very, very close in size and style. @tchrist – Shog9 Nov 4 '18 at 21:54
1

When writing by hand I always slash my zeroes and sevens.

Don't know which font does that (zeroes, 7 is already non-ambiguous) but I'd like to see it used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .