3

Recently, I have seen a couple of posts that I think were supposed to be migrated to SO, but weren't. Community locks them like it would for migrated questions and then almost immediately unlocks them. One example is https://unix.stackexchange.com/posts/727041/revisions. The 10k tools doesn't show anything odd.

6
  • That does sound like a bug. The post timeline has a bit more info for mods, and I see 5 votes to migrate to SO, so I don't understand why it would fail.
    – terdon Mod
    Dec 2, 2022 at 23:55
  • 1
    My only guess at this point is that the asker is/was Question-blocked on SO. Just a guess!
    – Jeff Schaller Mod
    Dec 3, 2022 at 1:29
  • @JeffSchaller that might be it. In the meantime I found the other post where I saw this happening: unix.stackexchange.com/questions/726935/…
    – muru
    Dec 3, 2022 at 2:14
  • If I'm right, meta.stackexchange.com/q/276407/307535 has some background. It might instead be tags? meta.stackexchange.com/q/318476/307535 ... but probably not, given the tags on these two questions.
    – Jeff Schaller Mod
    Dec 3, 2022 at 3:57
  • 1
    More canonical reference on failed migrations: meta.stackexchange.com/a/10250/307535
    – Jeff Schaller Mod
    Dec 3, 2022 at 3:58
  • The latter has a detailed flowchart which recommends not migrating questions with good answers unless they are at risk of deletion. That’s a criterion which we tend not to apply; I’ve had a few answers migrated to SO (with their parent question) after a few days, on questions which wouldn’t have warranted deletion here. (I don’t mind particularly, it always means more rep on SO…) Dec 5, 2022 at 12:26

1 Answer 1

3

The most likely cause, IMHO, is that the OP's are/were question-blocked on SO. The FAQ on migration says, in part, regarding blocked migrations:

What causes a migration to be blocked and what happens after?

  • The user is question-banned or suspended on the destination site, or is rate-limited due to question quality and the migration would cause them to exceed the rate limit
  • The question does not use any tags that exist on the destination site, with three exceptions ...
  • The question was cross-posted onto the other site (unless a moderator migrates)

Question 1:

  • had tags: linux, windows -- both available on SO
  • does not appear to have been cross-posted (at this point, and that's visible to me)
  • the user does not appear to be suspended on SO (at this time)
  • the user only has one question on SO from Nov 17th, making a rate-limit unlikely

... making a question-ban the most likely reason for this migration failure.

Question 2:

  • had tags: c, read -- of which "c" is available on SO
  • does not appear to have been cross-posted (at this point, and that's visible to me)
  • the user does not appear to be suspended on SO (at this time)
  • the user's newest SO post was over 4 months ago, making a rate-limit unlikely

... making a question-ban the most likely reason for this migration failure.

I can't say definitively, since I can't see how many deleted questions each user has, so this is just my best guess with what I can see. There may be other rate-limiting activities going on that I can't see, or cross-posted questions that are now deleted, that could also explain it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .