1

I recently started to use meta. I noticed that for me certain parts of meta are not functioning as expected. Since before the rollover to HTTPS there has been a number of issues e.g. non-matching certificates. Some of them were related to the HTTPS everywhere browser extension. This caused some users to not be able to log in although this was before the move to *.meta. There was also redirection issues since then which seem to be fixed.

I think it's excellent that SE has made the move to full HTTPS. I also understand that it's hard so it's great that all of the effort is being put in to transition fully. There are a few kinks that are still not ironed out while using Firefox with HTTPS everywhere.

  • The "Recent inbox messages" button at the top doesn't open the pop up menu. It just flashes briefly.
  • The inline help above the question text box never loads fully, the loading animation loops indefinitely.
  • Trying to insert an image doesn't work, clicking the button or pressing Ctrl+G just puts a grey overlay over the screen. Successive key presses just lead to darker grey overlays
  • When trying to post a question a red pop up box is displayed with the message "An error occurred submitting the question.".
  • The tag suggestions never load but can be input manually.

I am running an updated Arch GNU/Linux with Firefox 54.0.1 and HTTPS everywhere 5.2.9. These issues were fixed by disabling the "Stack Exchange (partial)" rules, this is of course not a correct solution though. I assume this can be fixed by a small change to the HTTPS everywhere ruleset. The linked page has a bug report link but I don't know enough of the technical details to post a good report. I hope this is something easily fixable so we can make this great site even better.

  • 2
    I don't see any of these with 5.2.20, so I assume it already got fixed. It's just "Stack Exchange", not "Stack Exchange (partial)" for me. – Michael Homer Jul 9 '17 at 23:47
  • That's a big derp on my part! Thanks for pointing out my out of date extensions. – rlf Jul 10 '17 at 0:39
2

As Michael Horner points out in the comments these problems have been fixed in a more recent version of HTTPS everywhere. My problem was that somehow I had turned off the auto updates of my Firefox extensions.

The solution is to Keep your system up to date!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .