2

My favorite browser is Mozilla Firefox and it works fabulously on most of the stackexchange sites but somehow that does not work in meta, i.e. the profile does not get transferred and I remain as a person without either being able to sign up or able to login. I am able to use the chat as well in stackexchange without any issues. Looking forward for some solution. Please see Login page . I am running Iceweasel 31.1.0 .

@Anthon I tried using the link https://unix.meta.stackexchange.com/questions/ask but get this :-

The page isn't redirecting properly

Iceweasel has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept cookies.  

@slm I tried clearing history but still no change.

Clueless, what to do next other than continue using chromium for talking on meta :(

Update: umm... I think I got the issue but dunno how to clear it up. I see this on the CLI if I start iceweasel via CLI and try to do the above.

HTTPS Everywhere: Redirection loop trying to set HTTPS on:
  http://unix.stackexchange.com/users/login?returnurl=https://unix.meta.stackexchange.com/questions/ask
(falling back to HTTP)

So seems it has to do with the ruleset of https anywhere with meta.unix.stackexchange.com.

This is the ruleset in HTTPS Everywhere as it now :-

<ruleset name="Stack Exchange (mixed content)" platform="mixedcontent">

    <target host="stackexchange.com" />
    <target host="*.stackexchange.com" />


    <securecookie host="\.stackexchange\.com$" name=".+" />


    <rule from="^http://(\w+\.)?stackexchange\.com/"
        to="https://$1stackexchange.com/" />

</ruleset>

This is where one can find more info. about httpseverywhere and how rulesets are made.

There is a bigger ruleset as well called stackexchange (partial) as well. Both rulesets are xml files :-

<!--
    Other Stack Exchange rulesets:

        - Ask_Ubuntu.com.xml
        - MathOverflow.net.xml
        - Server_Fault.com.xml


    Nonfunctional domains:

        - chat.stackexchange.com    (mixed content)
        - meta.*.stackexchange.com      (mismatched, CN: *.stackexchange.com)


    Problematic domains:

        - www.stackapps.com *

    * Mismatched


    Fully covered domains:

        - cdn-chat.sstatic.com
            - *.stackexchange.com


    Mixed content:

        - css on chat.stackexchange.com from cdn-chat.sstatic.net *

        - Images on chat.stackexchange.com, from:

            - www.gravatar.com *
            - i.stack.imgur.com *
            - cdn.sstatic.net *

        - Web bugs on *.stackexchange.com from pixel.quantserve.com *

    * Secured by us


    As of Dec., 2013, stackexchange has a cert valid for:

        - *.stackexchange.com
        - stackexchange.com
        - meta.stackexchange.com
        - *.meta.stackexchange.com
        - *.stackoverflow.com
        - stackoverflow.com
        - serverfault.com
        - stackauth.com
        - sstatic.net
        - meta.serverfault.com
        - superuser.com
        - meta.superuser.com
        - stackapps.com
        - openid.stackauth.com

-->
<ruleset name="Stack Exchange (partial)">

    <target host="blogoverflow.com" />
    <target host="www.blogoverflow.com" />
    <target host="sstatic.net" />
    <target host="*.sstatic.net" />
    <target host="stackapps.com" />
    <target host="www.stackapps.com" />
    <target host="stackexchange.com" />
    <target host="*.stackexchange.com" />
        <exclusion pattern="^http://(?:\w+\.)?stackexchange\.com/search\?" />
        <exclusion pattern="^http://chat\.stackexchange\.com/" />
        <exclusion pattern="^http://(?:\w+\.)?(stackexchange|stackoverflow)\.com/users/authenticate/" />
    <target host="stackoverflow.com" />
    <target host="*.stackoverflow.com" />
    <target host="app.stacktack.com" />
    <target host="superuser.com" />
    <target host="*.superuser.com" />


    <securecookie host="^\.sstatic\.net$" name=".+" />
    <securecookie host="\.stackexchange\.com$" name=".+" />


    <rule from="^http://(?:www\.)?blogoverflow\.com/$"
        to="https://stackexchange.com/blogs" />

    <rule from="^http://(?:(or\.)?cdn\.)?sstatic\.net/"
        to="https://$1cdn.sstatic.net/" />

    <rule from="^http://cdn-chat\.sstatic\.net/"
        to="https://cdn-chat.sstatic.net/" />

    <rule from="^http://(?:www\.)?stackapps\.com/"
        to="https://stackapps.com/" />

    <rule from="^http://(\w+\.)?stackexchange\.com/"
        to="https://$1stackexchange.com/" />

    <rule from="^https://(\w+\.)?stackexchange\.com/search\?"
        to="http://$1stackexchange.com/search?"
    downgrade="1" />

    <rule from="^http://(www\.|meta\.|careers\.)?stackoverflow\.com/"
        to="https://$1stackoverflow.com/" />

    <rule from="^http://app\.stacktack\.com/"
        to="https://s3.amazonaws.com/stacktackapp/" />

    <rule from="^http://(www\.|meta\.)?superuser\.com/"
        to="https://$1superuser.com/" />

</ruleset>

https://www.eff.org/https-everywhere/rulesets

  • Have you tried click /ask question that might force the system to prompt for login credentials and/or might re-evaluate your cookie information. – Anthon Nov 3 '14 at 10:03
  • Clear out all your history. Do everything from the beginning. – slm Nov 3 '14 at 11:53
1

The answer is the same as given on https://tor.meta.stackexchange.com/questions/203/tor-browser-can-only-access-se-meta-sites-if-i-disable-https-everywhere-entirely specifically

https://tor.meta.stackexchange.com/a/215/3547 . This is the right way to do it. Having to remember to do it each time would be a pain though :(

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .