Twice today I have clicked on the “edit” link for a post, spent several minutes working on it, and then clicked on “Save Edits”, only to be told

Another edit is awaiting approval for this post. Further edits cannot be submitted until the pending edit is reviewed.

enter image description here

So obviously somebody else submitted an edit on the same post while I was editing it (or maybe even before I started).  Why wasn’t the second person who tried to edit the post given a message like the above?

  • Related: Why can't I edit this post?? Sep 4, 2014 at 23:36
  • Just a guess, if the first editor cancel his edition, then your modification will be allowed. However if you were lock out at first due to modifcation pending, you wouldn't have a chance to edit.
    – Archemar
    Sep 5, 2014 at 13:44

1 Answer 1


Locking something requires that the lock gets released and sometimes that will not be done in the normal way, because an edit is not finished in a reasonable time. Given that people might go out for a coffee (and stop typing, which might be detectable) or that a connection might go down (but the editor could come back and continue). That means you have to have something like a timeout period that needs to be determined and implemented, but the question is of course what is a reasonable amount of time.

The site doesn't implement locking, but once you have enough points to be able to edit without the need of review, you can commit changes, even if someone else got in before you, assuming that you have more substantial edits (not sure how the system determines what is more substantial).

I know, as I have done a few edits, that it can take some time to edit a post, especially if someone who posted had no idea of how formatting works on this site, but a few minutes is IMHO quite a lot time.

  • Once you have enough points...you can commit changes, even if someone else got in before you -> I'm not sure what you mean. I have all privileges (short of actually being a moderator) and I still get the big red sorry message if I try to edit something with a pending edit that hasn't been approved (or disapproved, which takes more than one reviewer).
    – goldilocks
    Sep 7, 2014 at 20:55
  • @goldilocks It might be that I have only 'raced' against edits not needing reviews, but I have not seen that message for I don't know how long. When I get a message, it is that someone else got in and that my messages need to be more substantial. But that is of course no proof, I might just have been lucky, or faster with editing.
    – Anthon
    Sep 8, 2014 at 4:04
  • @goldilocks yes, that used to really bug me. Anthon's point holds for edits of posts that have no pending suggested edits. Unfortunately, and I consider this a bug, even if you have the rep to edit a post directly, you cannot do so if a lower rep user has submitted an edit that's pending approval.
    – terdon Mod
    Sep 8, 2014 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .