4

In the Review Queue, I came across a question where Gilles had already voted to close as a duplicate: the question and the duplicate.

However, when I attempted to vote to close, I was asked to select the duplicate, which I did, and was greeted with a message I had not seen before:

This question does not have an upvoted or accepted answer

and the "Close" button remained greyed out:


screenshot of dialogue

In the time that it has taken to write this question, someone else has successfully voted to close as the count now stands at (2).

  • Has there been a change to the way this works?

  • Do you require a certain amount of reputation to close as a duplicate if there is no accepted or upvoted answer on the propsed duplicate?

  • Is this a just a bug?

Update: now that a second vote has been cast, I am able to select the duplicate and vote to close.

  • Sorry, no repro. – Braiam Mar 14 '14 at 0:24
  • I voted up one of the A's on the Q so we could close against it. – slm Mar 14 '14 at 0:58
  • So, in the two years I have been here, I'd not encountered this before? And how did Gilles make the initial vote? – jasonwryan Mar 14 '14 at 1:03
  • It was +1 when he used it, then someone DV'd it to +1/-1. I UV'd it to +2/-1 to use it as a dup. This is the 1st time I've ever seen this as well. I've run into dups w/ no rep before, but not like this. – slm Mar 14 '14 at 1:03
  • I'd categorize this more as a race condition 8-) – slm Mar 14 '14 at 1:04
  • Then this is a bug in two ways: once someone has voted it as a duplicate, it should be eligible, and I would also argue that you should be able to vote as duplicate irrespective of upvoted answers. – jasonwryan Mar 14 '14 at 1:07
2

Ok, I've not been able to reproduce this but here are my thoughts:

  1. The first vote happened when the question had an upvoted answer.
  2. When you tried to vote, the upvoted answer lost it's vote or someone else downvoted.
  3. Now you can because people started to upvote the question.
  • #3 was b/c of me. I UV'd one of the A's. That's exactly what happened in looking at it again. It was +1, Gilles used it as a dup, someone DV'd it, then I tried to use it as a dup and was blocked by above, I UV'd the A to +2/-1, and then voted to close as dup. Someone has since UV'd the A to +3/-1. – slm Mar 14 '14 at 1:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .