12

I asked this question a while back, but I didn't get any satisfactory answers. After poking around the Internets for a while, I found what I was looking for. I'm all happy now, and I went to go answer my own question, but found that the "Answer your own question" button way greyed out, and the text box where you type the answer was missing.

Is it a new feature in SE, where you need to have a certain Rep to answer your own questions? I can answer other questions, including ones that already have answers, but not that specific one. I've reloaded the page several times, logged out and back in, cleared my cache, disabled my adblocker (which already had SE sites on a whitelist,) and all the other troubleshooting advice you'll get when you say you need help getting the Internet to work, but nothing seems to fix it.

  • Bleh, it took me like 10 tries to get this question asked. The first few, it had a little red box saying "There was an error submitting the question", and eventually it let me get through to solve the Captcha. – JamesTheAwesomeDude Mar 13 '13 at 14:44
  • Odd. There isn't anything in the privileges list about answering your own question, and the only thing that's close is "too quickly" in the new user restrictions (<10 rep), which clearly doesn't apply. – derobert Mar 13 '13 at 15:46
  • 2
    It's the opposite; they added a feature that lets you answer your own question while you're still writing the question. There is a time limit for brand new users/questions (it's buried under edit community wiki for some reason), but you have enough rep to not be hitting it, plus the question is plenty old enough. The answer textarea is supposed to be missing until you click the button, but I don't know why the button would be disabled. Looking into it – Michael Mrozek Mar 13 '13 at 15:53
  • Browser specs, if anyone cares: Chromium 27, Puppy Linux. :) – JamesTheAwesomeDude Mar 13 '13 at 16:03
  • Hover your cursor over the button. Do you get a bit of text popping up? – Shog9 Mar 13 '13 at 16:14
  • @Shog9 Nope, no notices, tooltips, or anything. – JamesTheAwesomeDude Mar 13 '13 at 17:31
  • Ha, ha - I'd made an updated dotpet, so DocSalvage edited his post to have the updated version that I'd submitted (and therefore knew about.) I'm not really irritated, so much as I just think it's kind of funny. :P – JamesTheAwesomeDude Mar 13 '13 at 17:43
  • Would you mind posting a screenshot of what you see when you visit the bottom of the page? – Shog9 Mar 16 '13 at 2:07
2

The textbox is supposed to be initially hidden when you're answering your own question (folks tend to mistake it as a way to follow up on other answers otherwise), but the button itself should be enabled.

There is both a rep restriction and a time-delay, but it's... 10 rep and 8 hours. Also, they only apply after you try to post. So you should be good either way.

Marking this as a bug, although I'll confess: I can't reproduce it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .